PDA

View Full Version : On demand pump running



dalehollow
07-13-2015, 08:16 PM
The Head on demand pump, continues to run when not needed, isn't pumping water to the head but is running. Does pump water when I flush. Won't quit running
Excuse the poor explanation,

Hope some of you used to dealing with these pumps may know what I need to try,
Neighbor suggested it might be sucking air at the small glass strainer,coming from stand pipe
Said check gasket


I have just been s/w it off till I can figure it out, or need to flush

easttnboater
07-14-2015, 06:20 AM
It is not holding pressure or thinks it is not holding pressure. Could be the pressure switch, could be a leak internal to the pump.

Stmbtwle
07-14-2015, 06:58 AM
Possibly simply debris in the pump. Is there a strainer? What type of pump and how old is it? You may need a new a new "kit", the rubber valves do fail eventually. Easy to fix.

dalehollow
07-16-2015, 03:41 PM
I'll take a look at the pump its self an. See the brand thinking a sure flo. About 10 years old, thought I'd look at the gasket on the strainer filter. Normally I take the jar off annually an check it for debri an any trash in the jar. In size the strainer is about 2 inches diameter. 4 inches. Long as I recall

Stmbtwle
07-17-2015, 10:24 AM
Shurflos are modular and easy to repair. If the problem isn't in the strainer, replace the valve assembly and you should be good to go. Worst Marine can get it for you.

There is a chemical-resistant assembly that will probably last longer. Call shurflo.