houseboat magazine
Your Ultimate Online Houseboating Resource
Welcome to Houseboat Magazine
Contact UsAdvertise

AFTERMARKET MANUFACTURERS BROKERS FORUMS
Administered by The Pirate
+ Reply to Thread
Results 1 to 7 of 7

Thread: Westerbeke 12.5BEG generator issues

  1. #1
    Senior Member GoVols's Avatar
    Join Date
    Aug 2011
    Location
    Nashville, TN
    Posts
    365

    Westerbeke 12.5BEG generator issues

    I woke the genset from its winter slumber Friday only to find it behaving worse than I do before my morning coffee. Gen is an '05 12.5Kw BEG model with about 320 hours on it. Iíve never had a problem out of this thing.

    Through some Googling, I learned the generator is doing what's called "hunting." Under normal operation, it's supposed to run at a steady 1,800RPM. Instead, it's rhythmically fluctuating between 1,800 ~ 2,000RPM very rapidly, like a drum beat. It's doing this with no load and when loaded. While loaded, it's greatly exacerbated.

    Spark plugs were new in the fall before initial winterization. Fuel tank was properly treated before winter and fuel is shared with one of my propulsion motors, which is running fine. Generator was winterized in early Oct, but then ran for 8 hours straight for our annual boat parade in December, where it performed flawlessly. After the parade, it was immediately rewinterized.

    Thus far, I have performed the following to troubleshoot this issue: removed and thoroughly cleaned the carb; verified 2 built-in fuel filters werenít clogged; checked governor oil level; changed governor oil (10w-30); cleaned linkage; inspected / cleaned distributor cap, points, rotor; adjusted idle speed. Fuel and delivery to motor is good. There's no unusual odors, fluids in exhaust (oil / unburned fuel), or sounds coming from system.

    During all of this, the motor is not sputtering or running rough at all, so I'm compelled to think that there's nothing mechanically wrong with the engine, but possibly electrical.

    I read that there's an electromagnetic sensor that counts the teeth on the flywheel and tells the governor how to regulate the engine RPM, however, I can't find that sensor. If that's not it, maybe the governor is bad altogether, but I've heard that's extremely rare.

    Any ideas?
    '06 Sailabration located on Percy Priest Lake

    Bet On Another Thousand

  2. #2
    Senior Member easttnboater's Avatar
    Join Date
    Nov 2002
    Location
    GA
    Posts
    462
    You might want to also post this over on boatered.com - there is a bigger audience over there and some experienced folks.

  3. #3
    Senior Member GoVols's Avatar
    Join Date
    Aug 2011
    Location
    Nashville, TN
    Posts
    365
    Repairman got to my boat this morning and had it "fixed" within an hour. He had to adjust the speed and hertz settings. I asked if he put a load on it to confirm everything worked - he hadn't, despite my original request and leaving the doors unlocked for power panel acess. He said he'd walk back down the dock and try it out. I immediately left work and drove ~15 minutes to the boat and the guy was already gone. I started the gen and it worked fine. I then put a load on the generator and the A/C wouldn't even kick on b/c there's not enough power. I called the guy back and he's now coming BACK AGAIN tomorrow.
    Last edited by GoVols; 05-22-2014 at 11:58 AM.
    '06 Sailabration located on Percy Priest Lake

    Bet On Another Thousand

  4. #4
    Senior Member GoVols's Avatar
    Join Date
    Aug 2011
    Location
    Nashville, TN
    Posts
    365
    Well, repairman has visted my boat now a total of 5 times to work on the gennie and is due back again tomorrow. So far he's adjusted the governor 8 ways from Sunday and then figured the governor was bad. He installed a new $750 governor this morning, but that didn't fix the problem either. He now believes the voltage regulator board to be bad, which is another $300 part. He said that should fix it, but if it doesn't, he's pretty much out of ideas. Let's hope that 6th time is a charm! It's looking like this is going to cost me $1.5 Boat Buck$ to get boating season started.
    '06 Sailabration located on Percy Priest Lake

    Bet On Another Thousand

  5. #5
    Senior Member easttnboater's Avatar
    Join Date
    Nov 2002
    Location
    GA
    Posts
    462
    I feel your pain. Last year I spent 3 of them just to replace a $10 O ring. Sometimes, you have to pay to play. Hopefully, it will get fixed and you get on with enjoying the boat.

  6. #6
    Senior Member GoVols's Avatar
    Join Date
    Aug 2011
    Location
    Nashville, TN
    Posts
    365
    Tech fixed it on the 6th visit. It turned out to be the voltage regulator circuit board, not the governor. The tech apologized several times and was clearly disappointed in his own performance in diagnosing and fixing the issue. He said he'd never seen one of these boards go bad before. My '05 model gennie only has 310 hours on it, so that's something you wouldn't expect to wear out....at any age really! He hasn't billed me yet, so I'm waiting for that. He told me he wouldn't bill me when he left the boat the 1st 4 times.

    The gen worked very well for us the whole Memorial weekend. I probably put another 15 hours on it in 2.5 days on the water. I don't run the gen when we're anchored and swimming. I have a 3,500 W inverter system with an large battery bank that'll carry our activities for the better part of the day. At night, we leave the windows open and run fans. I generally run the gen a few hours each morning and evening to cook breakfast / dinner and charge the batteries for the day / night.
    '06 Sailabration located on Percy Priest Lake

    Bet On Another Thousand

  7. #7
    Senior Member GoVols's Avatar
    Join Date
    Aug 2011
    Location
    Nashville, TN
    Posts
    365
    Got the bill. $1,700! Damn.
    '06 Sailabration located on Percy Priest Lake

    Bet On Another Thousand

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts