houseboat magazine
Your Ultimate Online Houseboating Resource
Welcome to Houseboat Magazine
Contact UsAdvertise

AFTERMARKET MANUFACTURERS BROKERS FORUMS
Administered by The Pirate
+ Reply to Thread
Page 4 of 4
FirstFirst ... 2 3 4
Results 31 to 39 of 39

Thread: Westerbeke EFI generator issues

  1. #31
    Senior Member easttnboater's Avatar
    Join Date
    Nov 2002
    Location
    GA
    Posts
    654
    Did you perform the trouble shooting process that is in the manual that is in post #15?

  2. #32
    Junior Member
    Join Date
    Nov 2016
    Posts
    18
    Yes. We keep finding more things to test too. Still on our investigation.

  3. #33
    Senior Member Stmbtwle's Avatar
    Join Date
    Apr 2003
    Location
    Ruskin, Florida
    Posts
    2,477
    It's been two weeks... what did you find?
    She's a tired old barge but she's paid for!

  4. #34
    Super Moderator OLD HOUSEBOATER's Avatar
    Join Date
    Oct 2002
    Location
    Tavares Florida
    Posts
    1,909
    Putting my money on a head gasket.

    Rodney
    The fries are cold so we gave you extra.

  5. #35
    Senior Member 42gibson's Avatar
    Join Date
    Nov 2010
    Location
    norwich,ohio
    Posts
    475
    did you run a compression test?
    44 gibson executive
    on the muskingum river & ohio river
    marietta,ohio

  6. #36
    Senior Member Stmbtwle's Avatar
    Join Date
    Apr 2003
    Location
    Ruskin, Florida
    Posts
    2,477
    I'm beginning to think the problem has been found and fixed, and it was one of those simple little issues that is just too embarassing to report. Been there!

    Comon Ltrdays, 'fess up!
    She's a tired old barge but she's paid for!

  7. #37
    Junior Member
    Join Date
    Nov 2016
    Posts
    18
    Problem finally solved!!! YAY!! It was the speed sensor. Thank you everyone for your great advise.

  8. #38
    Senior Member Stmbtwle's Avatar
    Join Date
    Apr 2003
    Location
    Ruskin, Florida
    Posts
    2,477
    Glad you found it! I know how frustrating such issues can be.
    She's a tired old barge but she's paid for!

  9. #39
    Member
    Join Date
    Jul 2012
    Location
    Pacific Northwest
    Posts
    97
    Where does the fuel draw from? What tank? I know this isn't a good example, but the same thing happened with the Onan generator on my motorhome. After much ado (like you are going through) it turned out that the fuel was drawn from the same tank as the MH's engine but did not go to the bottom of the tank. When the fuel got down to between 1/4 and 1/3 full, bingo, no more fuel to the genny. Filled up the tank and it ran like a champ. Point is the symptoms were the same as yours. And if it was water getting into the cylinders, yu would have seen it on the plugs.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts