houseboat magazine
Your Ultimate Online Houseboating Resource
Welcome to Houseboat Magazine
Contact UsAdvertise

AFTERMARKET MANUFACTURERS BROKERS FORUMS
Administered by The Pirate
+ Reply to Thread
Results 1 to 7 of 7

Thread: Electrical Readings

  1. #1
    Senior Member
    Join Date
    Jul 2012
    Location
    Wheeling, WV
    Posts
    196

    Electrical Readings

    As all of you know, I had some corrosion issues with my Aluminum Hulled Kingscraft. I finally got the electrical rewired and corrected. I took some readings again and I am now trying to determine what other steps that I need to take.

    I used the reference electrode from Boat Zincs to take my readings. In their instructions they state that my Hull Potential should be between -900mV and -1200mV. While unplugged from shore power, my boat's reading is -1050mV. When plugged into Shore Power, my reading is -588mV. That is well out of the range for adequate protection. After unplugging a neighboring houseboat, whom we know has electrical issues, my reading is -800mV. I am still -250mV from the reading when I am unplugged. I believe there are more offenders at my dock contributing to the issue and I am going to address it with the marina. However, I have a couple of questions about the galvanic isolator. Should my readings be exactly the same from unplugged to plugged in with the GI installed? Would I still see the large difference in Potential even with the GI installed? I am going to give BoatZincs.com today to discuss this as well.

  2. #2
    Senior Member GoVols's Avatar
    Join Date
    Aug 2011
    Location
    Nashville, TN
    Posts
    300
    Sorry I can't contribute here, but I just wanted to say that my boat does not have a galvanic isolator and am wondering if it's truely necessary to have it. I've priced these things anywhere from $100 - $500 and can't tell the difference between any of them. I require a 50 AMP unit - that's all I know. My neighbors have one installed and he said there's always a green light on it, which indicates no problems. I'm wondering if that means there's no current in the water around his boat, so maybe mine is OK as well?

    Your boat is in fresh water, isn't it?
    '06 Sailabration located on Percy Priest Lake

    Bet On Another Thousand

  3. #3
    Senior Member easttnboater's Avatar
    Join Date
    Nov 2002
    Location
    Tennessee
    Posts
    395
    I don't think that it means that there is not current leaking from his boat. It just means that there is no current coming onto his boat through the shore power ground. My understanding is that a galvanic isolator keeps current from entering your wiring from the shore power ground. You can still have internal wiring problems that put current on ground.

    So, GoVols - just because he is OK does not necessarily mean that you are. I guess that if you trust his green light and you plugged his boat into your receptacle and you still had a green light, then it would prove that at that moment you did not have current on ground at your receptacle.

  4. #4
    Senior Member 42gibson's Avatar
    Join Date
    Nov 2010
    Location
    norwich,ohio
    Posts
    306
    when in doubt, ask old houseboater. if he doesnt know he sure knows someone who will.

  5. #5
    Super Moderator OLD HOUSEBOATER's Avatar
    Join Date
    Oct 2002
    Location
    Gulf Shores Alabama
    Posts
    1,679
    JTA

    You have a private message

  6. #6
    Senior Member
    Join Date
    Jul 2012
    Location
    Wheeling, WV
    Posts
    196
    Just an update on the situation. We have determined that it is just the one single boat at the dock. When we unplug him from the shore it does go up to around 800. However when he moves his entire boat out of the marina the readings go to normal. He was the only boat that was out on the water at that time. I have offered my services to get his wiring in order. We'll see if he will take the help or not.

  7. #7
    Senior Member
    Join Date
    Jul 2012
    Location
    Wheeling, WV
    Posts
    196
    Well my above post was incorrect. Yes we did see improved readings when the other boat was out of the marina, but not normal readings. After consulting Bob at Boatzincs.com he confirmed that I should see no difference between readings when plugged into shore power and off shore power with the galvanic isolator installed. He then told me to put an ammeter around the shore power cable to see if I was part of the stray current. I did so and I was indeed part of the problem. After not understanding how this could be bypassing the GI as I redid the entire 120 panel, I remembered what a fellow Kingscraft owner had told me. The shore power connector on my boat was all metal with metal screws holding it to the front of the boat. This was the only place that could be bypassing the isolator. I had purchased an all plastic connector from my friend's recommendation, but had never installed it. After removing the connector and installing the plastic one, my electrical readings became rock solid. I can finally rest. Now it is time for something else to break.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts