Over the weekend, I had a new issue crop up. The starboard upper helm controls wouldnít turn on for some reason when I turned the key. Lower helm worked fine as did the complete port side controls. I had to start the motor at the lower helm and then transfer control to the upper micro commander in order to drive the boat. The upper starboard gauges never did come on. I also noticed that the plug for my battery charger in the rear starboard locker isnít working. I didnít work on it much, but tried the plug's breaker on the shore power panel and the GFI reset button on the plug itself, but the plug wonít give me any juice. Iím wondering if the 2 issues are related. I tried jiggling the wires inside the upper helm, but that didnít bring the power back on either. This wouldn't be such an issue if the depth sounder on the lower helm worked, but I now have no way of knowing how deep the water is. Also, I can't always hear my motors out back, so I rely on my tachs to tell me if the motor is running - now I can't.

Any ideas?